Thank you for your donation!


Official moOde 7.2.1 support thread
#1
Hi,

Post all bug reports and questions concerning moOde 7.2.1 or the in-place update for 7.2.0 -> 7.2.1 in this thread. 

Please paste log output, scripts, etc in code boxes for readability.

-Tim
Reply
#2
Running version 7.2.0. Check for software update tells me my software is up to date.
Reply
#3
(05-07-2021, 10:27 PM)Tim Curtis Wrote: Hi,

Post all bug reports and questions concerning moOde 7.2.1 or the in-place update for 7.2.0 -> 7.2.1 in this thread. 

Please paste log output, scripts, etc in code boxes for readability.

-Tim
Raspberry pi 3b+, updated from 7.2.0 to 7.2.1. Everything is fine. After updating to version 7.2.1, the Audio info section displays the correct information about DSD256 and DSD512.
 Thank you! )))
Reply
#4
Running mpd_oled.

I use an I2C OLED and add i2c-dev to '/etc/modules'. The Moode 7.2 and 7.2.1 upgrades reset this file and so I had to add the line again. Is there a place I could add this line that would survive an upgrade. It seems like a popular module, could it be enabled by default? (Volumio does this).

I am unsure exactly of the exact sequence of events, but the spectrum analyser component was not working after the upgrade. On investigation, I found that the ALSA Loopback option was set to ON, but the overide had not been enabled in '/etc/alsa/conf.d/_sndaloop.conf' (it looked like 'pcm.!_audioout__ {'). Also, I wasn't able to change the option as the loopback device was in use by mpd_oled/cava. I stopped mpd_oled, set the loopback to OFF and saved, then set it to ON and saved, and this fixed the issue.

Adrian.
Reply
#5
The in-place updates contained the default versions of the files below. I'll repackage it this morning without those files. Hopefully this will avoid unnecessary support.

Code:
/etc/alsa/conf.d/_audioout.conf
/etc/alsa/conf.d/_deviceout.conf
/etc/alsa/conf.d/_sndaloop.conf
/etc/modules

As far as i2c-dev module goes, if ALSA loopback is set to ON in Audio Config it's loaded dynamically at that time and during moOde startup and thus does not need to be specified in /etc/modules however if it's listed in /etc/modules then nothing bad will happen when attempting to load dynamically via modprobe snd-aloop.
Reply
#6
Hi Tim

My comment was about the i2c-dev module, rather than the snd-aloop module.

Adrian.
Reply
#7
lol, not enough coffee this morning.

Btw the repackaged in-place update has been uploaded.
Reply
#8
I also can't seem to pickup the in-place update. I get 'software is up-to-date' quite quickly. I've rebooted, tried again, powercycled, tried again but no download seems to be triggered and the system info stays at 7.2.0.

I'm happy to look at the log, but I couldn't find the location to use (logging in via putty). A sticky in FAQs and Guides might be a good idea.

Thanks,

Skip
Reply
#9
(05-08-2021, 09:04 PM)Skip Pack Wrote: I also can't seem to pickup the in-place update. I get 'software is up-to-date' quite quickly. I've rebooted, tried again, powercycled, tried again but no download seems to be triggered and the system info stays at 7.2.0.

Running two Moode installs. Both report 7.2.0 is "up to date." I have accessed them both from different PCs. phones and a tablet.
Reply
#10
Prolly some caching is happening on your Browser or Router. Try running the update from ssh.

Code:
sudo /var/www/command/updater.sh r720
Reply


Forum Jump: