Thank you for your donation!


Issue with deleted Stereo Test File
#1
Photo 
Deleted the Stereo Test File on SD Card, but a entry (unknown) is still available in library.
I updated music source, database and reboot without any luck. How can I get rid of this entry?

Thanks in advance


Attached Files Thumbnail(s)
   
Reply
#2
Menu, Configure, Sources

Reset Library cache
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#3
I already try it but didn't specify it above.
Is there another option or a workaround?
Reply
#4
Then most likely the code that generates the Library is missing a case to handle a "no songs" condition. I'll add to the TODO list to investigate but low priority since its rare to not have any songs.

-Tim
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#5
Right Tim, it's not so impotant.

I add a file back on SDCARD and leave it there. The "unknown track" entry is now named again.

Thanks!
Reply
#6
(08-31-2018, 01:52 PM)Tim Curtis Wrote: Then most likely the code that generates the Library is missing a case to handle a "no songs" condition. I'll add to the TODO list to investigate but low priority since its rare to not have any songs.

-Tim

I can repro this condition with a fresh install of r42. 

1. After install, the only configured source is the SDCARD so the only track present is /mnt/SDCARD/Stereo Test/LRMonoPhase4.flac
  • The Browse view lists four entries: USB (empty), NAS (empty), SDCARD (only the one directory and file), Default Playlist.
  • The Library view lists the one track per its metadata.
2. Delete the file and rescan/reset.
  • The Browse view still lists the four entries; under SDCARD the Stereo Test directory is listed and empty.
  • The Library view lists an unknown/unknown/unknown track as @poposchmatzer identified.
3. As well, delete the /mnt/SDCARD/Stereo Test directory and rescan/reset.
  • Now the Browse view list only one entry, the Default Playlist.
  • The Library view continues to list the unknown/unknown/unknown track.
 
Operationally, it doesn't matter but it feels odd that the Browse view drops out all three empty device directories here where before it was happy to list two empty device directories in order to get to the third, non-empty SDCARD directory.

This post doesn't need a response. Just something to keep in mind when you get to this item on the ToDo list Rolleyes

Regards,
Kent
Reply
#7
Hi Kent,

Any stale Browse entries can be cleared via the new dedicated refresh btns on the r43 panels :-)

-Tim
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply


Forum Jump: