Thank you for your donation!


Official moOde 8 support thread
#1
Bug 
Hi,

Post all bug reports and questions concerning moOde 8 in this thread.

Please paste log output, scripts, etc in code boxes for readability.

-Tim
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#2
Christmas in March! Setting up the image on the first of my moOde Pi's. Can't wait to start playing/listening to it. Thanks!
Reply
#3
Code:
uname -a

Linux moode 5.15.23-v7+ #1525 SMP Wed Feb 16 14:34:22 GMT 2022 armv7l GNU/Linux

Looks like the kernel is not immune to the "Dirty Pipe" vulnerability, which was fixed in kernel 5.15.25.

https://dirtypipe.cm4all.com/

Any chance of an update to fix this?

I can use rpi-update to work around this in my environment, but others may find things break if they go down that route.

Otherwise, it looks good so far.

Thanks Tim and the team,

Phil

Reply
#4
We will prolly do a kernel bump in the first in-place update.
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#5
Re: updating the kernel

Here's a data point.

I installed moOde 8 on a Pi Zero 2 W. This works fine with my Creative USB BT-W2 adapter / Sennheiser headphones.

Ran sudo rpi-update

This takes me to kernel 5.15.27-v7+

moOde 8 and the Creative adapter continue to work fine.

I'll try the update on my RPi 4B / Khadas Tone 1 Board later tonight.

Regards,
Kent
Reply
#6
The main issue with updating the kernel is that it won't include the 4 patched drivers that we ship with a release. Kernel drivers are compiled to a specific kernel version. If you don't need the capabilities that these patched drivers provide then its a non-issue.

Patched drivers

Code:
aloop       Add 384K rate
ax88179     For the ASIX ETH/USB chip on Allo USBridge Signature
pcm1794a    Add 384K rate
rtl88xxau   For Comfast CF-912AC dual band Wifi adapter

Another issue with bumping the kernel is that there can be other types of breakage. It's always best to stay with the kernel version that ships with a given moOde release because it's the one that is used during testing by the crew and its the one that we provide support and troubleshooting  for :-)
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#7
smb music source not mounting anymore;
same share in v.7 worked flawlessy

flags are ro,dir_mode=0777,file_mode=0777,vers=1.0

here the log:
20220314 004429 sourceMount(): Mount error: (Retrying with upper case share name
mount error(6): No such device or address
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg))

here dmesg:
[ 24.895241] Use of the less secure dialect vers=1.0 is not recommended unless required for access to very old servers
[ 24.895260] CIFS: VFS: Use of the less secure dialect vers=1.0 is not recommended unless required for access to very old servers
[ 24.895273] CIFS: Attempting to mount \\192.168.1.1\usb1_sda1
[ 25.044161] CIFS: VFS: \\192.168.1.1 failed to connect to IPC (rc=-6)
[ 25.045225] CIFS: VFS: cifs_mount failed w/return code = -6
[ 25.045387] Use of the less secure dialect vers=1.0 is not recommended unless required for access to very old servers
Reply
#8
Remove "vers=1.0" from the mount flags and do a SCAN to select the share. The SMB version should be automatically detected by the SCAN and used in the mount but it won't appear in the mount flags string.
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#9
Downloaded, installing it soon.
Reply
#10
(03-14-2022, 12:16 AM)Tim Curtis Wrote: Remove "vers=1.0" from the mount flags and do a SCAN to select the share. The SMB version should be automatically detected by the SCAN and used in the mount but it won't appear in the mount flags string.

it dont work

mount error(6): No such device or address

Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg))


[ 2777.355272] CIFS: Attempting to mount \\192.168.1.1\usb1_sda1
[ 2777.361217] CIFS: VFS: \\192.168.1.1 failed to connect to IPC (rc=-6)
[ 2777.362123] CIFS: VFS: cifs_mount failed w/return code = -6
[ 2777.362275] Use of the less secure dialect vers=1.0 is not recommended unless required for access to very old servers
Reply


Forum Jump: