Thank you for your donation!


Messy Cover Art in MoodeAudio 4.3
#1
                Hello Tim,

compliments for your work on MoodeAudio 4.3.
Picture 000 shows the cover art view, which is very attractive for the eye.
(And to impress my friends!)



Question: cover art is messy, I tried everything to fix it, maybe it a bug or something else?
All cover art is embedded and correct in the settings.
Picture 001 shows the same cover for different files.
Picture 002 shows the correct cover under it.
Picture 003 shows the cover from the test file which is on the SC card!

Hoping to get a solution, I love MoodeAudio!

Dig-It
Reply
#2
Hi,

With regard to embedded art:

- The algorithm used in the thumbnail generator results in the LAST track in each Album directory being used to create the cover thumbnail. 
- The algorithm used to display the cover art in the Library Tracks section uses the FIRST track in each Album directory.
- The algorithm used in the Playback panel uses the selected track for displaying cover art.

For example I have an Album by Nine Inch Nails named The Slip. Each track has a different embedded cover. The last tracks' cover shows up in the Album panel grid. The first tracks' cover shows up in the Library Tracks section.

Another scenario that will break thumbnail grid display is when there are directories that contain tracks from different albums, typically to be used as compilations, and where the tracks contain different embedded cover art. It will always be the cover from the last track in the dir that is shown in the Album grid.

For example an album dir named 80's Pop.

-Tim
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#3
Hi Tim, I have some similar problems. At the beginning, some albums used jpg in folders and some used embedded covers. Now I understand why...
But, I now have tried to fix it by using cover.jpg in each folder and deleting embedded covers.
But now when I select an album, thumbnails are right but nothing appear when choosing an album or even playing it !
Is it normal behavior now ?
The point is that in moode 4.2 I do not have this problem : covers with albums using cover.jpg in folder and no embedded cover use to display normally even in playback tab ?

thx
Rasptouch case with RPI3 + I2C 16x2 screen and IR port
Audiophonics I-Sabre V2.1 DAC ES9023 TCXO
Reply
#4
You can set cover display priority in the customization settings now, no need to delete them from your music files unless you want to reclaim a little space.

Covers not appearing when selected or during playback isn’t normal but you’ll need the “covers whisperer” aka Tim to help sort out why that’s happening.
Reply
#5
Yep I know and it's done. Yes the idea was to gain some space.
I'll wait for him  Blush
Rasptouch case with RPI3 + I2C 16x2 screen and IR port
Audiophonics I-Sabre V2.1 DAC ES9023 TCXO
Reply
#6
(10-11-2018, 06:54 PM)BlackSmile Wrote: Hi Tim, I have some similar problems. At the beginning, some albums used jpg in folders and some used embedded covers. Now I understand why...
But, I now have tried to fix it by using cover.jpg in each folder and deleting embedded covers.
But now when I select an album, thumbnails are right but nothing appear when choosing an album or even playing it !
Is it normal behavior now ?
The point is that in moode 4.2 I do not have this problem : covers with albums using cover.jpg in folder and no embedded cover use to display normally even in playback tab ?

thx

Definitely not normal. The thumbnail generator uses essentially the same routines as the coverart extractor, the module thats used to display covers on the Playback panel and Library tracks section. There is a cover search priority setting on the Customize screen that tells the thumb generator and coverart extractor what to look for first (embedded or cover image file) but either way if it can't find one type it looks for the other.

Zip up one of the albums and email me a download link. I'll try and repro the issue.

-Tim
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#7
Hi Tim,

I also got problems displaying album images in cover art. I set cover display priority to separate cover image file, in my case 'cover.jpg'. If this is the only file in the root directory of the cd, everything works fine. But in many cases I got additional image files, i.e. cd.jpg, back.jpg, etc. It seems to be, that the - alphabetically - first image file will be used by the thumbnail generator. And: when I select this 'wrong' thumbnail, the cd tracks will be listed near by the correct 'cover.jpg'.

I'm not a php specialist, so I don't understand in detail how thmcache.php works.

Hope this helps a little bit.

Regards, Klaus
Reply
#8
(10-11-2018, 10:02 PM)d1kmm Wrote: Hi Tim,

I also got problems displaying album images in cover art. I set cover display priority to separate cover image file, in my case 'cover.jpg'. If this is the only file in the root directory of the cd, everything works fine. But in many cases I got additional image files, i.e. cd.jpg, back.jpg, etc. It seems to be, that the - alphabetically - first image file will be used by the thumbnail generator. And: when I select this 'wrong' thumbnail, the cd tracks will be listed near by the correct 'cover.jpg'.

I'm not a php specialist, so I don't understand in detail how thmcache.php works.

Hope this helps a little bit.

Regards, Klaus

Hi, I had the same problem. To solve it the easy way is to create a subfolder and put them in it.
Rasptouch case with RPI3 + I2C 16x2 screen and IR port
Audiophonics I-Sabre V2.1 DAC ES9023 TCXO
Reply
#9
(10-11-2018, 10:02 PM)d1kmm Wrote: Hi Tim,

I also got problems displaying album images in cover art. I set cover display priority to separate cover image file, in my case 'cover.jpg'. If this is the only file in the root directory of the cd, everything works fine. But in many cases I got additional image files, i.e. cd.jpg, back.jpg, etc. It seems to be, that the - alphabetically - first image file will be used by the thumbnail generator. And: when I select this 'wrong' thumbnail, the cd tracks will be listed near by the correct 'cover.jpg'.

I'm not a php specialist, so I don't understand in detail how thmcache.php works.

Hope this helps a little bit.

Regards, Klaus

Hi Klaus,

Thanks for the clear description of the issue. A quick look at the thumbnail code and I think this might be a bug :-0

I'm seeing a fall-thru from the code block that tries to find the standard named cover image files (cover.jpg, folder.jpg, etc) to the code block that looks for the first "any_name.jpg", "any_name.png" etc. The first code block should exit if it finds one of the standard named files.

-Tim
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#10
Hi @BlackSmile,

I downloaded your test album. Thanks :-)

I'll run some tests over next couple of days.

-Tim
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply


Forum Jump: