Thank you for your donation!


External SSD not recognised
#1
Hi All,

For the past week, I've been pulling my hair out trying to use a Kingston SSD 480 gb with a usb adapter where I store music files, to rpi3b+piano+kali with Moode. I could not get it to work or appear on the Moode interface.

I've gone through a number of forums. Tried ntfs and exfat formats, dynamic disks. By the way, the disk works fine in windows 7.
Some commented a lack of power, so I am now using 5v 19amp meanwell smps. Still could not get it to work.

Although I do not have expertise in linux, I tried some suggested commands like dmesg and lsusb.

One thing I notice on the result of the command lsusb, which may or may not even have a bearing, is this:

I have another external HDD drive which works fine. The difference between this and the SSD is that in the working HDD,
the device is listed as "Bus 001 Device 005: ID 125f:a31a A-DATA Technology Co., Ltd." whereas in the SSD it is,
"Bus 001 Device 004: ID 2537:1068".

On the command dmesg there is a mention of the SSD drive, as below:
"
pping ok
[    5.191520] .
[    5.537839] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    5.537866] brcmfmac: power management disabled
[    5.873627] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[    5.873846] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    6.231463] .
[    6.756218] scsi 0:0:0:0: Direct-Access     ATA      KINGSTON SA400S3 61K1 PQ                                                                             : 0 ANSI: 6
[    6.757168] sd 0:0:0:0: Attached scsi generic sg1 type 0
[    6.757457] sd 0:0:0:0: [sdb] 937703088 512-byte logical blocks: (480 GB/447                                                                              GiB)
"

Any help would be appreciated.
Reply
#2
moOde auto-mounts USB disks to the /media directory using the disk label. For example if you have labeled your disk MySSD then it would be mounted as below after plugging it in.

/media/MySSD

What is the output from the command below
ls /media
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#3
(11-03-2018, 05:34 PM)Tim Curtis Wrote: moOde auto-mounts USB disks to the /media directory using the disk label. For example if you have labeled your disk MySSD then it would be mounted as below after plugging it in.

/media/MySSD

What is the output from the command below
ls /media

Hi Tim,

Thanks for response. 
It has my other HDD named Music-nas only.
It does not have any other label.

Regards.
Reply
#4
I just unplugged and plugged the SSD again and run dmesg and I found that
my adapter has this label: Norelsys NS1068. I hope this helps.
This is part of the result:

[ 4993.511324] sd 0:0:0:0: [sdb] Attached SCSI disk
[ 5112.814589] usb 1-1.4.1: USB disconnect, device number 16
[ 5118.570969] usb 1-1.4: USB disconnect, device number 15
[ 5118.570978] usb 1-1.4.2: USB disconnect, device number 17
[ 5119.009559] usb 1-1.4.3: USB disconnect, device number 18
[11636.621569] usb 1-1.4: new high-speed USB device number 19 using dwc_otg
[11636.752276] usb 1-1.4: New USB device found, idVendor=2537, idProduct=1068
[11636.752283] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[11636.752288] usb 1-1.4: Product: NS1068
[11636.752292] usb 1-1.4: Manufacturer: Norelsys
[11636.752296] usb 1-1.4: SerialNumber: 0123456789ABCDE
[11636.752734] usb-storage 1-1.4:1.0: USB Mass Storage device detected
[11636.754706] scsi host0: usb-storage 1-1.4:1.0
[11639.296912] scsi 0:0:0:0: Direct-Access ATA KINGSTON SA400S3 61K1 PQ: 0 ANSI: 6
[11639.297434] sd 0:0:0:0: Attached scsi generic sg1 type 0
[11639.298191] sd 0:0:0:0: [sdb] 937703088 512-byte logical blocks: (480 GB/447 GiB)
[11639.298488] sd 0:0:0:0: [sdb] Write Protect is off
[11639.298499] sd 0:0:0:0: [sdb] Mode Sense: 43 00 00 00
[11639.298792] sd 0:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[11639.309981] sdb: sdb1 sdb2
[11639.313394] sd 0:0:0:0: [sdb] Attached SCSI disk
Reply
#5
The disk label is something that you would have input when you formatted the disk.
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#6
Yes, I named it MusicBox. But it is not there in ls /media.
Reply
#7
You could try formatting it as a single VFAT (Fat32) partition, specify MBR partition table if you are given a choice between MBR and GUID partition table, and also give it a disk label.

If it still doesn't auto-mount then its probably some sort of compatibility issue between the drive and Linux, or some other kind of issue with the formatting or partitioning.
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#8
Hi Tim,
I digged around for the adapter and found this:
https://git.kernel.org/pub/scm/linux/ker...0c279a3fe9

My adapter chip seems to have mounting problem:
"The UAS mode of Norelsys NS1068(X) is reported to fail to work on
several platforms with the following error message:
xhci-hcd xhci-hcd.0.auto: ERROR Transfer event for unknown stream ring slot 1 ep 8
xhci-hcd xhci-hcd.0.auto: @00000000bf04a400 00000000 00000000 1b000000 01098001

And when trying to mount a partition on the disk the disk will
disconnect from the USB controller, then after re-connecting the device
will be offlined and not working at all.

Falling back to USB mass storage can solve this problem, so ignore UAS
function of this chip."

The solution seems to be a linux source code change.
I have no programming skills. How do I go about it?

In the meantime I have followed the raspbian update command and formatted my disk as MBR, exfat, which
is still processing.

Thanks & Regards,
Kay
Reply


Forum Jump: