Thank you for your donation!


Bad quality sound on MoodeAudio 6.x
#11
(08-31-2019, 08:41 AM)ghoeher Wrote: I can't remember which EQ settings I used in Moode 5.x but I can confirm that already with the default settings of the "Hi-Lo Boost Plus"-EQ settings of Moode 6 which Jedreck is using (with modifications), I also have distorted sound with my Justboom Amp Hat.
And Jedreck's settings are even more extreme than the default "Hi-Lo-Boost Plus" ones, which increase the distortion in an ugly way in my environment.

When reducing the three lower bands a little bit compared to the "Hi-Lo Boost Plus" Settings, sound is ok again.

As Swizzle wrote, instead of increasing the EQ levels, use boosting with care and better reduce the frequencies you don't want to boost.


As I currently can't compare to 5.x, I don't know if the sound/distortion is different on 5.x with the same EQ settings. But in general for me the sound quality of 6.x is as good as with 5.x, if the EQ is configured in the way I like the sound.

That's why I moved the equalizer settings from moodeaudio 5 to moodeaudio 6 that they are just the way I like them. It's only in version 5, because in version 6 it's not. I will try to change (decrease) the gain and settings of all bands by the same value and then we will see how it sounds.
Reply
#12
@Jedrek I still don't know if it sounds non distorted if you turn all EQ off. You've probably answered your own question, you can't transfer your chosen EQ settings from v5 to v6 successfully, so you either need to revert to v5 where you were happy with the sound or amend the EQ so that v6 sounds acceptable.
You mentioned I think in another thread that you'd made changes to the EQ in v6 & you thought the sound was "flat" but then how fabulous the sound in v5 was.
Maybe v5 is the sweet spot for you?
Reply
#13
Imho it is very simple….
Setting the wrong sampling rate for SoX can you give hugh distortions. You (@Jedrek ) probably though that upscaling to the highest bitrate and frequency would give you the best result.
Maybe you thought wrong... I even believe your DAC, the HifiBerry DAC+ Pro, can't even handle these settings.

And just as everybody else here says: put the EQ back to flat level, I would also say (for the second time) disable this SoX parameter. Start from scratch...If you're still not happy, change one parameter at a time. Don't just copy what you had in an older version…
 Angry
Reply
#14
(08-31-2019, 02:00 PM)JST1963 Wrote: Imho it is very simple….
Setting the wrong sampling rate for SoX can you give hugh distortions. You  (@Jedrek ) probably though that upscaling to the highest bitrate and frequency would give you the best result.
Maybe you thought wrong... I even believe your DAC, the HifiBerry DAC+ Pro, can't even handle these settings.

And just as everybody else here says: put the EQ back to flat level, I would also say (for the second time) disable this SoX parameter. Start from scratch...If you're still not happy, change one parameter at a time. Don't just copy what you had in an older version…

Ok.
I will try again.
HifiBerry DAC+ Pro can handle these settings. no any system problems.

Please don't close this thread … i will answer when i find the acceptable settings
Reply
#15
(08-31-2019, 11:18 AM)Jedrek Wrote: That's why I moved the equalizer settings from moodeaudio 5 to moodeaudio 6 that they are just the way I like them. It's only in version 5, because in version 6 it's not. I will try to change (decrease) the gain and settings of all bands by the same value and then we will see how it sounds.

The first step in debugging your problem is to try to narrow down what is causing the problem.  If you disable EQ and the distortion goes away, we know that the problem is related to EQ.  If the distortion remains with EQ off, then we can try other things, like SoX resampling.  When we find the root cause, then Tim and other developers can investigate whether some change from 5.x to 6.x is responsible.

I have a suspicion that there may be clipping occurring somewhere, but let's visit the EQ and SoX first and see what we find.  If the problem goes away when the EQ is off, then I want to reduce the overall output level, either through ALSA volume or by setting analog gain to -6dB.  If that fixes it, we can figure out why later.
Cheers,
  Miss Sissy Princess
Reply
#16
(08-31-2019, 05:26 PM)Jedrek Wrote: HifiBerry DAC+ Pro can handle these settings.
The maximum supported sampling rate is 192kHz according to the manufacturer.  There's also no point feeding a 32 bit signal into a DAC with a SINAD of -92dB.  That's 4dB shy of the dynamic range of a 16 bit audio CD, there is no reason to pump 20, 24, or 32 bit samples into it (other than convenience if the music's native format has samples larger than 16 bits).

Disable SoX resampling.  It won't improve the sound and it may degrade it. You don't get something for nothing.  Blowing up a 16 bit/44.1 kHz track to 32 bit/352.8 kHz is like taking a 400x400 pixel JPEG image and blowing it up to 4196 x 4196.  It doesn't get sharper as a result.

(08-31-2019, 05:26 PM)Jedrek Wrote: Please don't close this thread … i will answer when i find the acceptable settings

Don't try to "find the acceptable settings." Just perform the specific tests and tell us the results so that we could help debug the issue you describe.  The goal here is not just to make your sound better.  It's to determine if there is a problem in the software (app, OS, or driver) that needs to be fixed to benefit many people.

  1. Have you turned the EQ off to see if the distortion goes away?  I don't care whether you want it on, or whether it was on in moOde 5.x.  Set Parametric EQ and Graphic EQ to "Off."  Then listen and tell us whether the distortion goes away.
  2. Have you disabled SoX resampling?  If not, disable it and tell us whether the distortion goes away.
  3. Have you set Analog Gain to -6dB?  If not, please do so and tell us whether the distortion goes away.  Note that this will decrease the overall volume, but you can compensate for that elsewhere.
Please perform those steps and tell us what happens.
Cheers,
  Miss Sissy Princess
Reply
#17
Hello Friends
I was tested many setting of EQ, and SoX.
On result (for me) the any setting of SoX (with disabling too) not changing of sound quality, and I was enable it - without changes.
I was create new setting of EQ and i was select any parameters for best quality sound, but it is completty different than my setting from MoodeAudio 5.3.
Now sound is clear and good, but louder.
On first step i was decrease any EQ point for 10 points for down (default is 66 and i decrease for 56) and then i setting any point up separatelly.
Now Is have good sound (subjective opinion).

ps. I love the Hard-rock and punk rock musics.
Resume: eq settings on Moodeaudio 5.3 are not compatible (on sound quality) with moodeaudio 6.x. Please search own setting !
This topic can be closing by Admin.
Thanks for all.

On my opinion, default audio signal level on moodeaudio 6.x is bigger than default audio signal level on moodeaudio 5.x. This is a simple problem with audio distrortions and corresponding EQ settings.
Reply
#18
(09-07-2019, 10:49 PM)fmaxwell Wrote:
(08-31-2019, 05:26 PM)Jedrek Wrote: HifiBerry DAC+ Pro can handle these settings.
The maximum supported sampling rate is 192kHz according to the manufacturer.  There's also no point feeding a 32 bit signal into a DAC with a SINAD of -92dB.  That's 4dB shy of the dynamic range of a 16 bit audio CD, there is no reason to pump 20, 24, or 32 bit samples into it (other than convenience if the music's native format has samples larger than 16 bits).

Disable SoX resampling.  It won't improve the sound and it may degrade it. You don't get something for nothing.  Blowing up a 16 bit/44.1 kHz track to 32 bit/352.8 kHz is like taking a 400x400 pixel JPEG image and blowing it up to 4196 x 4196.  It doesn't get sharper as a result.

(08-31-2019, 05:26 PM)Jedrek Wrote: Please don't close this thread … i will answer when i find the acceptable settings

Don't try to "find the acceptable settings." Just perform the specific tests and tell us the results so that we could help debug the issue you describe.  The goal here is not just to make your sound better.  It's to determine if there is a problem in the software (app, OS, or driver) that needs to be fixed to benefit many people.

  1. Have you turned the EQ off to see if the distortion goes away?  I don't care whether you want it on, or whether it was on in moOde 5.x.  Set Parametric EQ and Graphic EQ to "Off."  Then listen and tell us whether the distortion goes away.
  2. Have you disabled SoX resampling?  If not, disable it and tell us whether the distortion goes away.
  3. Have you set Analog Gain to -6dB?  If not, please do so and tell us whether the distortion goes away.  Note that this will decrease the overall volume, but you can compensate for that elsewhere.
Please perform those steps and tell us what happens.

Ad. 1. If I turned off EQ then the signal audio is without distortion ! (only with moodeaudio 6.x, because with moodeaudio 5.x this setting is allways without distortions)
Ad. 2. On me, the any changes of setting SoX (on/off) ot changes sound quality !
Ad. 3. I was write on previous post, …. any settings for analog not changing and eliminate distortions, because distortions was created on digital signal, before converting to analog. 
Reply
#19
FWIW on the SoX resampling the reason people do it is that most DACs will convert things internally to a higher rate to make their filters work better. The idea is that you can (sometimes, depending on DAC) do a better job in the conversion using SoX. Read down to the filter talk here:

https://www.audioholics.com/audio-techno...ital-audio
Reply
#20
Hi. According to forum rules, I'm not starting a new thread, since this one already exists and complies with my issue (I hope so Smile )

I've got a brand new Rpi4 + Hifiberry DAC+ Pro. Naturally, I installed the latest Moode 6.5.2 release, since this is my first time experience with it. The setup went smooth, music playback works fine.
However, when I enable Graphic EQ, the sound becomes distorted. This happens, with both volume control set to Software or Disabled, but in case of Software I am able to remove the distortion by lowering the volume. Now, with Disabled option, no matter what I do (set output to -6 dB, decrease ALSA volume to 50 etc), the distortion is still there. The only workaround is to completely disable the EQ. Also, JFYI, I'm not using SoX resampling, and the EQ I use is Vinyl Touch.
Searching this forum for similar reports I came across few other posts, where people complain for exact same thing, and from what I learned so far, it was OK on Moode 5. So, if their assumption is correct, Moode 6 uses higher volume on digital side, which introduces distortion at least with this DAC when EQ is on.

Let me know, if you need more information. It would be great to have a fix in near future. Thank you!
Reply


Forum Jump: