Thank you for your donation!


Feature Request: On Screen Keyboard
#1
In the last couple of days I built a small Moode-based system with a touch screen. I activated the local UI, and it works wonderfully.
However, I also noticed I have quite a few artists in my library, which makes scroling through the list somewhat tedious.
I would love to be able to use the search feature on teh local UI as well. However currently there is no on screen keyboard available.
Would it be possible to have this feature?

thanks,

Hendrik-Jan
Reply
#2
Hi Hendrik-Jan,

See Build Recipe 2.4 COMPONENT 8 - Local UI display, Step 4 Configure Chrome Browser

Code:
////////////////////////////////////////////////////////////////
//
// COMPONENT 8 - Local UI display
//
////////////////////////////////////////////////////////////////

1. Install xserver. Perform this step separately from the rest.

sudo apt-get -y install xinit xorg lsb-release xserver-xorg-legacy chromium-browser libgtk-3-0

2. Permissions, clean up and service config

sudo sed -i "s/allowed_users=console/allowed_users=anybody/" /etc/X11/Xwrapper.config
sudo apt-get clean
sudo systemctl daemon-reload
sudo systemctl disable localui

4. Configure Chrome Browser

NOTE: These steps are performed AFTER actually starting local display via System config,
rebooting and then accessing moOde on the local display.

a. Connect a keyboard.
b. Press Ctrl-t to open a separate instance of Chrome Browser.
c. Enter url chrome://flags and scroll down to Overlay Scrollbars and enable the setting.
d. Optionally, enter url chrome://extensions and install the xontab virtual keyboard extension.

-Tim
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#3
Ok, now I feel stupid. Undecided
Thank you Tim!

--edit: 27.05.2018

I just followed your steps. This works great, and looks very nice.
Thanks a lot once more Tim, for a very nice audio solution!
Reply
#4
(05-24-2018, 09:41 PM)Tim Curtis Wrote: Hi Hendrik-Jan,

See Build Recipe 2.4 COMPONENT 8 - Local UI display, Step 4 Configure Chrome Browser

Code:
////////////////////////////////////////////////////////////////
//
// COMPONENT 8 - Local UI display
//
////////////////////////////////////////////////////////////////

1. Install xserver. Perform this step separately from the rest.

sudo apt-get -y install xinit xorg lsb-release xserver-xorg-legacy chromium-browser libgtk-3-0

2. Permissions, clean up and service config

sudo sed -i "s/allowed_users=console/allowed_users=anybody/" /etc/X11/Xwrapper.config
sudo apt-get clean
sudo systemctl daemon-reload
sudo systemctl disable localui

4. Configure Chrome Browser

NOTE: These steps are performed AFTER actually starting local display via System config,
rebooting and then accessing moOde on the local display.

a. Connect a keyboard.
b. Press Ctrl-t to open a separate instance of Chrome Browser.
c. Enter url chrome://flags and scroll down to Overlay Scrollbars and enable the setting.
d. Optionally, enter url chrome://extensions and install the xontab virtual keyboard extension.

-Tim

Hi Tim and Hendrik Jan,

Thanks for your information. I did on my Moode device what you described Tim and it works fantastic. Great!

Casper
Reply


Forum Jump: