Thank you for your donation!


Idea: codec selector (switcher)
#1
Hi,

There was a little problem that audiophile codec conflicts to FFmpeg codec with playback aiff and wav, 
so how about to add "codec selector/switcher" section to MPD menu, which can edit codec's enable/disable in mpd.conf via web UI?

Thanks,
kitamura_design
Reply
#2
I could do that but I think we will be ok with just ffmpeg :-)
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#3
(10-16-2018, 12:01 PM)Tim Curtis Wrote: I could do that but I think we will be ok with just ffmpeg :-)


Yes, we would...

Question: Is it impossible to implement FDK-AAC codec? I heard it is impossible due to its license.

kitamura_design
Reply
#4
IDK but usually anything from Fraunhofer will be proprietary. Debian/Raspbian includes the faad2 decoder which I think is licensed under GPLv2. https://packages.debian.org/stretch/libfaad2

faad2 is what MPD uses to decode AAC files.
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#5
(10-16-2018, 06:08 PM)Tim Curtis Wrote: IDK but usually anything from Fraunhofer will be proprietary. Debian/Raspbian includes the faad2 decoder which I think is licensed under GPLv2. https://packages.debian.org/stretch/libfaad2

faad2 is what MPD uses to decode AAC files.

I Got If I want to listen the FDK's, I have to build MPD and ffmpeg by myself.
At least, I think the aac codec on ffmpeg provides better sound than faad's. 
Would you compare them?

kitamura_design
Reply
#6
You should be able to specify "no" in the ffmpeg decoder block in /etc/mpd.conf. This should force MPD to use the faad decoder instead of the ffmpec aac decoder for file.aac. 


decoder {
plugin "ffmpeg"
enabled "no"
}
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#7
(10-17-2018, 06:44 PM)Tim Curtis Wrote: You should be able to specify "no" in the ffmpeg decoder block in /etc/mpd.conf. This should force MPD to use the faad decoder instead of the ffmpec aac decoder for file.aac. 


decoder {
plugin "ffmpeg"
enabled "no"
}
I already did like this;



decoder {
plugin "faad"
enabled "no"
}

decoder {
plugin "ffmpeg"
enabled "yes"
}

kitamura_design
Reply
#8
You can confirm which codec MPD selects by turning on "verbose" logging in /etc/mpd.conf, then restart MPD, then view the log

cat /var/log/mpd/log | grep decoder
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#9
(10-18-2018, 01:00 PM)Tim Curtis Wrote: You can confirm which codec MPD selects by turning on "verbose" logging in /etc/mpd.conf, then restart MPD, then view the log

cat /var/log/mpd/log | grep decoder

Hi,

Would you see below;
Code:
$ cat /var/log/mpd/log | grep decoder
Oct 18 23:03 : ffmpeg/aac: If you heard an audible artifact, there may be a bug in the decoder. Clipped noise gain (-190 -> -100)
Oct 18 23:03 : ffmpeg/aac: If you heard an audible artifact, there may be a bug in the decoder. Clipped noise gain (-190 -> -100)
Oct 18 23:03 : ffmpeg/aac: If you heard an audible artifact, there may be a bug in the decoder. Clipped noise gain (-190 -> -100)
Oct 18 23:03 : ffmpeg/aac: If you heard an audible artifact, there may be a bug in the decoder. Clipped noise gain (-190 -> -100)
Oct 18 23:03 : decoder_thread: probing plugin ffmpeg
Oct 18 23:03 : decoder: audio_format=44100:f:2, seekable=false

Looks ffmpeg/aac is working, but saying there's some bug. However there doesn't appear any clipped noise.
Reply
#10
I saw different strange lines in the log when I played my test m4a files that MPD determined needed the ffmpeg aac decoder.

Convert the files to FLAC and all will be good :-)
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply


Forum Jump: