Thank you for your donation!


pydPiper python program for displays
#11
(05-02-2018, 01:16 PM)TheOldPresbyope Wrote:
(05-02-2018, 10:15 AM)rikardo1979 Wrote: OK, so I have tried the suggestions but no help

But now I have tried to install latest Volumio, which on the pydPiper suppose to be working on, to find it does not.
Exactly same behaviour as on the moOde, just the 'STOP' is constantly displayed

Did you use the file pydpiper.service with only an edit to choose/configure the correct ExecStart line? I just noticed the file's header section
Code:
[Unit]
Description=pydPiper container
Requires=docker.service
After=volumio.service

Presumably your installation enabled and started docker.service (mine did) but there is no volumio.service in moOde.

I've been installing step-by-step so I understand what's going on. There's volumio-isms like the one above and also differences between what I see in the github dhrone/pydPiper (master) repo and what's in the dhrone/pydpiper-v0.31-alpha docker image. The repo README.md, for example, is more descriptive of the image and hasn't completely caught up with the repo. Stay tuned.

So far, I have the latest Docker installed (not what you get if you use the repo's install_docker.sh) and running the pydpiper docker image in a container. That's working fine (essentially it's a cut-down raspbian wheezy running on the host kernel which right now is 4.14.32-v7+). I haven't gotten to running pydPiper as a service in moOde. [Bear with me and my shifting camel case; I'm trying to be consistent with the naming convention of the author.]

It turns out I was overly optimistic earlier. I don't have an OLED or LCD display in my motley parts collection, so my plan is to test pydPiper in moOde using curses (e.g., the terminal) as my display. I got the hint from the existence of the file pydPiper/displays/lcd-curses.py

Of course, you may well get across the goal line before me.

Regards,
Kent

Amendment: I may have caused some confusion here. Turns out the master-branch README.md on the github site specifies downloading an archived version of pydPiper, v0.3-alpha.tar.gz. The install.sh in this version does install the latest Docker engine. Consistent with Step 2 in the README.md, the pydpiper.service file specifies the docker image dhrone/pydpiper:latest which differs from dhrome/pydpiper:v0.31-alpha. It's not clear what version the tag "latest" refers to but some of the file dates in that image are earlier than in v0.31-alpha. To quote Walter Scott, "oh what tangled webs we weave...."

yes I have edited the line. I have tried all sorts of combinations but with  no affect.
Reply
#12
(05-02-2018, 06:53 PM)rikardo1979 Wrote: yes I have edited the line. I have tried all sorts of combinations but with  no affect.

Isn't this fun?

After reading the code, I realized my plan to build upon lcd_curses.py is naive. Instead, I'm sticking some software probes in pydPiper.py itself. Experiments take time because I have to jump back and forth between running the service on the host (moOde) and editing the Docker image from inside a Docker container. (Yes, there are other ways to do this but I'm bulling my way forward.)

As well, I have a few "real life" tasks that need attending to if I'm to stay out of the doghouse Wink 

Regards,
Kent
Reply


Forum Jump: