Thank you for your donation!


Solved: Can't connect NAS
#1
Hello,

I've recently set up the latest moode on my RPi 3. I'm trying to connect it to a NAS attached to my router(Nighthawk X10) which moode correctly finds while scanning. The error I'm getting is:

20180809 093913 wrk_sourcemount(): Mount error: (username specified with no parameter)

If I try to add some username or password, I get the following:

20180809 093827 wrk_sourcemount(): Mount error: (mount error: could not resolve address for READYSHARE: Unknown error)

Any ideas?
Reply
#2
I have Synology and use NFS works great. Scan never worked for me. If you would like to give NFS a shot and you have questions let me know.
Reply
#3
(08-09-2018, 07:37 PM)saikzor Wrote: Hello,

I've recently set up the latest moode on my RPi 3. I'm trying to connect it to a NAS attached to my router(Nighthawk X10) which moode correctly finds while scanning. The error I'm getting is:

20180809 093913 wrk_sourcemount(): Mount error: (username specified with no parameter)

If I try to add some username or password, I get the following:

20180809 093827 wrk_sourcemount(): Mount error: (mount error: could not resolve address for READYSHARE: Unknown error)

Any ideas?

Post a screen shot or list the values you entered on the NAS config screen and I'll have a look.
Enjoy the Music!
moodeaudio.org | Mastodon Feed | GitHub
Reply
#4
Not sure what values you mean. Is this good? https://imgur.com/0WI5KM4 https://imgur.com/ZJVChng
Reply
#5
I need to see moOde's NAS config screen or optionally just list the values you entered in the screen.
Enjoy the Music!
moodeaudio.org | Mastodon Feed | GitHub
Reply
#6
(08-10-2018, 12:19 AM)Tim Curtis Wrote:
(08-09-2018, 07:37 PM)saikzor Wrote: Hello,

I've recently set up the latest moode on my RPi 3. I'm trying to connect it to a NAS attached to my router(Nighthawk X10) which moode correctly finds while scanning. The error I'm getting is:

20180809 093913 wrk_sourcemount(): Mount error: (username specified with no parameter)

If I try to add some username or password, I get the following:

20180809 093827 wrk_sourcemount(): Mount error: (mount error: could not resolve address for READYSHARE: Unknown error)

Any ideas?

Post a screen shot or list the values you entered on the NAS config screen and I'll have a look.

(08-10-2018, 02:48 PM)Tim Curtis Wrote: I need to see moOde's NAS config screen or optionally just list the values you entered in the screen.

Is this not it? https://i.imgur.com/ZJVChng.png
Reply
#7
Yes, thats it.

Try entering Guest for User ID and leave Password blank.

-Tim
Enjoy the Music!
moodeaudio.org | Mastodon Feed | GitHub
Reply
#8
(08-10-2018, 05:23 PM)Tim Curtis Wrote: Yes, thats it.

Try entering Guest for User ID and leave Password blank.

-Tim

Tried that, does not work. I get the following error:

20180810 141001 worker: Job sourcecfg
20180810 141002 wrk_sourcemount(): Mount error: (mount error: could not resolve address for READYSHARE: Unknown error)
20180810 141002 src-config(): Job: updmpddb
20180810 141005 worker: Job updmpddb
Reply
#9
(08-10-2018, 06:11 PM)saikzor Wrote:
(08-10-2018, 05:23 PM)Tim Curtis Wrote: Yes, thats it.

Try entering Guest for User ID and leave Password blank.

-Tim

Tried that, does not work. I get the following error:

20180810 141001 worker: Job sourcecfg
20180810 141002 wrk_sourcemount(): Mount error: (mount error: could not resolve address for READYSHARE: Unknown error)
20180810 141002 src-config(): Job: updmpddb
20180810 141005 worker: Job updmpddb

The Linux utility smbtree can find your server's name READYSHARE but the Linux mount command can't resolve it into an IP address (local DNS/Avahi may not be running). 

Try using the "EDIT server manually" option to enter your server as <IP address>/share. Something like 192.168.1.123/USER instead of READYSHARE/USER (or whatever; I can't tell if the whole share name is displayed in your screen capture).

Hope this helps.

Regards,
Kent
Reply
#10
(08-10-2018, 06:24 PM)TheOldPresbyope Wrote:
(08-10-2018, 06:11 PM)saikzor Wrote:
(08-10-2018, 05:23 PM)Tim Curtis Wrote: Yes, thats it.

Try entering Guest for User ID and leave Password blank.

-Tim

Tried that, does not work. I get the following error:

20180810 141001 worker: Job sourcecfg
20180810 141002 wrk_sourcemount(): Mount error: (mount error: could not resolve address for READYSHARE: Unknown error)
20180810 141002 src-config(): Job: updmpddb
20180810 141005 worker: Job updmpddb

The Linux utility smbtree can find your server's name READYSHARE but the Linux mount command can't resolve it into an IP address (local DNS/Avahi may not be running). 

Try using the "EDIT server manually" option to enter your server as <IP address>/share. Something like 192.168.1.123/USER instead of READYSHARE/USER (or whatever; I can't tell if the whole share name is displayed in your screen capture).

Hope this helps.

Regards,
Kent

This solved it. Thanks!
Reply


Forum Jump: