Thank you for your donation!

Problem: Can't connect to NAS
(12-17-2018, 10:28 PM)Onionhead Wrote: No problems connecting NAS with moOde from 3.8 forward. I use a Synology DS415 Play and ORBI router. I have a mesh wi-fi network and never been able to get SAMBA scan to find my NAS so I use NFS only. Here are some suggestions for anyone interested in NFS config that works for me.

1. make sure the shared folder permission includes the pi running moOde
2. if possible setup an IP reservation for the pi running moOde
3. Edit server manually for example  - Pay attention to upper lower case naming conventions
4. Clear browser cache
5. shutdown moOde and turn off pi. 
6. reboot router
7. powerup pi

Hi Onionhead, Tim, Kent,

Thanks. It works now. 

I took the steps Onionhead mentioned, but in first phase it did not work. Then in de NAS settings I changed under NFS / Permissions the squash to  "root to admin" in the created line for the pi - moode (static number).  The page for NFS /Permissions in the NAS, the path is mentioned at the bottom. In my case "/volume1/Volume_1".  By entering in moode it didnot worked, but by entering NFS and ""  it is working Big Grin Big Grin Big Grin

(12-16-2018, 04:23 PM)Tim Curtis Wrote: Post a screen shot of NAS Config

Attached Files Thumbnail(s)
(12-16-2018, 04:26 PM)TheOldPresbyope Wrote: @julessilver

Are you comfortable using SSH to work from the command line of your moOde player? (moOde's builtin Web SSH Terminal works great.) Then, let's bypass moOde's NAS configuration panel.

From the command line, can you successfully ping the hostname SynNAS? Does the ping response include the IP address you expect (apparently 

Example: here's what I get pinging my server OMV-HC1 (note u/l-case doesn't matter in the hostname):

pi@moode:~ $ ping omv-hc1 -c 1
PING omv-hc1.fios-router.home ( 56(84) bytes of data.
64 bytes from omv-hc1.fios-router.home ( icmp_seq=1 ttl=64 time=3.50 ms

--- omv-hc1.fios-router.home ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 3.508/3.508/3.508/0.000 ms

From the command line you can test-mount your username/password-protected SMB share (note that u/l-case doesn't matter in hostname/share but it very much does matter in username and password):

mkdir /tmp/test
sudo mount -t cifs //<hostname or ip>/<sharename> /tmp/test -o username=xxx,password=yyy

# examples assuming the hostname is SynNAS, the IP address is,
# the username is jules, and the password is yyy
# sudo mount -t cifs //SynNAS/Music /tmp/test -o username=jules,password=yyy
# or
# sudo mount -t cifs // -o username=jules,password=yyy

NOTE ADDED IN EDIT: the mount command is a single line; reading my completed post in my browser it is folded at "-o" into two lines)

(If you leave off the password option, you'll be prompted for it; if you leave off the username option, interesting things happen if the share is protected).

If you can successfully mount it, then un-mount it with (note the odd spelling of the command)

sudo umount /tmp/test

If the username and/or password is wrong in the mount command, you should see---wait for it---"mount error (13), permission denied". This is what I see repeatedly in your log.

As for NFS, I don't use it but you can test in a similar way:

sudo mount -t nfs <hostname or ip>:/<sharename> /tmp/test <nfs-options>

Note that there's no nfs option for a username/password. you'll have to dig into NFS documentation to sort out how to deal with the raft of options (both on the server end and the client end).

Hope this helps.

Hi Kent.

Went through your excellent instructions and decided it was the Synology NAS that was at fault. So I made a new admin user and password and re attached the NAS storage using the new credentials.

All works well. now.

Thanks for all your help. 

Your attention to detail is impeccable.

Best regards...jules

That's great!


Forum Jump: