Thank you for your donation!


Official moOde 7.0.1 support thread
#81
Hi,
Reposting #36

I have a problem, when playing songs, everything is fine, when the system is paused or stopped (no more song playing), after 20 minutes the system get stuck, cannot login ssh, or access UI anymore from any devices.
I can see that chromium memory jumped to 75% here(usually 15%) and kswapd0 7%CPU.

What could be the problem?
Do you need to see any log? (hard to get a log when everything is stuck)
Moode acted like that since I first installed 7. At first I thought it was because of a modification, spectrum, boot up splash screen, shutoff button, but with no mod, it's still getting stuck.
I have Local display enable for 3.5" screen
Alain

After more than an hour Moode got unstuck, and the local display is not showing the UI anymore, just a white page with "Aw, snap! Error..."


System info

Code:
S Y S T E M   P A R A M E T E R S

moOde release = 7.0.1 2020-12-23
RaspiOS = 10.6
Linux kernel = 5.4.77-v7+ #1371
Platform = Pi-3B+ 1GB v1.3
Architecture = armv7l (32-bit)
System uptime = up 4 hours, 7 minutes
Timezone = America/New_York
Current time = 2020-12-30 14:25:17

Host name = moode
Ethernet address = 192.168.1.7
Ethernet MAC = b8:27:eb:8d:ee:12
WLAN address = unassigned
WLAN MAC = no adapter
WLAN country = US

SoC identifier = bcm2837
Core count = 4
Kernel timer freq = 100 Hz
SDCard freq = 25 MHz
USB boot = enabled
Warranty = OK

Root size = 29G
Root used = 10%
Root available = 25G
Root expand = expanded
Memory free = 517 MB
Memory used = 172 MB
SoC temperature = 56.9°C

CPU governor = ondemand
Onboard WiFi = Off
Onboard BT = Off
HDMI output = On
LED state = 1,1
Eth addr wait = On
USB auto-mounter = udisks-glue
Max USB current = Off
USB (UAC2) fix = Off
SSH term server = Off

PHP-FPM version = 7.3.19
NGINX version = 1.14.2
SQLite3 version = 3.27.2
Hostapd version = 2.8-devel
WiringPi version = 2.50
RPi.GPIO version = 0.7.0

A U D I O   P A R A M E T E R S

Audio device = HiFiBerry DAC+ Pro
Interface = I2S
Mixer name = Digital
Hardware mixer = Yes
Max ALSA volume = 100
Max MPD volume = 100
Volume step limit = 10
Display dB volume = Off
Audio source = Local
Output device = Local
Resume MPD = No
Volume knob = 20
Volume mute = Unmuted
Saved MPD vol = 0
Preamp volume = 0
ALSA version = 1.1.8-1+rpt1
SoX version = 0.1.2-3

Bluetooth controller = Off
Pairing agent = Off
Airplay receiver = Off
Spotify receiver = On
Squeezelite = Off
UPnP client = Off
DLNA server = Off
GPIO button handler = Off
UPnP browser = Off

Auto-shuffle = Off
Ashuffle mode = Track
Ashuffle filter = None
Autoplay = Off
Rotary encoder = Off
Encoder params = 100 2 3 23 24
USB volume knob = Off
Polarity inversion = Off
Crossfeed = Off
Crossfade = Off
Parametric EQ = Off
Graphic EQ = Off
MPD httpd = Off

P R E F E R E N C E S

Appearance
----------------------
Theme = Nightshade
Accent color = Carrot
Alpha blend = 1.0
Adaptive background = No
Background image = No
Cover backdrop = No
Cover blur = 20px
Cover scale = 1.25
Renderer backdrop = No
Font size = Normal

Playback
----------------------
Show Queue thumbs = Yes
Show extra metadata = album,genre,track,disc,date,composer,conductor,performer,encoded
Search site = Google
Playback history log = No

Library
----------------------
One touch action = Play
Albumview sort order = by Artist
Tagview sort order = by Artist
Recently added = 1 Month
Show sample rate = No
Cover search pri = Embedded cover
Pixel ratio = 1
Thumbnail resolution = Auto
Thumbnail columns = 6/2 (Default)

Library (Advanced)
----------------------
Tag view artist = Artist
Album key = Album@Artist (Default)
Include comment tag = No
Library filter = full_lib
Library filter str =
Ignore articles = a,an,the
Show tagview genres = Yes
Show tagview covers = Yes
Ellipsis limited text = No
UTF8 character filter = No

CoverView
----------------------
Automatic display = 60
Backdrop style = Gradient (Linear)

R A D I O   M A N A G E R   S E T T I N G S

Sort tag = Name
Group method = No grouping
Show moOde stations = No action
Show other stations = No action

M P D   S E T T I N G S

Version = 0.22.3_p0x3
Volume mixer = software
ALSA device = hw:0
SoX resampling = disabled
Selective resampling = disabled
SoX quality = high
SoX multithreading = off
DSD over PCM (DoP) = no
Replaygain = off
Replaygain preamp = 0
Volume normalization = No
Audio buffer = 4 (MB)
Output buffer size = 128 (MB)
Max playlist items = 16384
Input cache = Disabled

B L U E T O O T H   S E T T I N G S

Bluetooth ver = 5.50
Bluealsa ver = v3.0.0
Speaker sharing = No
Resume MPD = No
PCM buffer time = 500000 (µs)

A I R P L A Y   S E T T I N G S

Version = 3.3.6
Friendly name = Moode Airplay
ALSA device = hw:0
Interpolation = soxr
Output bit depth = S16
Output sample rate = 44100
Session interruption = no
Session timeout = 120 (ms)
Latency offset = 0.0 (secs)
Audio buffer = 0.2 (secs)
Resume MPD = No

S P O T I F Y   S E T T I N G S

Friendly name = Moode Spotify
ALSA device = plughw:0
Bit rate = 320
Initial volume = 20
Volume curve = Logarithmic
Volume normalization = No
Normalization pregain = 0
Autoplay = No
Resume MPD = No

S Q U E E Z E L I T E   S E T T I N G S

Version = 1.9.7-1270 "DSD/SRC enabled"
Friendly name = Moode
ALSA device = hw:0
ALSA params = 80:4::1
Output buffers = 40000:100000
Task priority = 45
Codec list = flac,pcm,mp3,ogg,aac,alac,dsd
Other options = -W -D 500 -R E -S /var/local
Resume MPD = No

L O C A L   D I S P L A Y   S E T T I N G S

Local UI display = On
Mouse cursor = Off
Screen blank = 20 Secs
Wake display on play = On
Brightness = 20
Pixel aspect ratio = Default
Rotate screen = 0 Deg

M O O D E   S T A R T U P   L O G

20201230 101728 worker: -- Start
20201230 101728 worker: Successfully daemonized
20201230 101729 worker: Integrity check (passed)
20201230 101729 worker: File check (OK)
20201230 101729 worker: Session loaded
20201230 101729 worker: Debug logging (OFF)
20201230 101729 worker: -- Device
20201230 101729 worker: ALSA cards: (0:sndrpihifiberry | 1:empty | 2:empty | 3:empty
20201230 101729 worker: Configured: (0:HiFiBerry DAC+ Pro | mixer:(Digital) | alsavol:0)
20201230 101729 worker: ALSA mixer actual (Digital)
20201230 101730 worker: ALSA Digital volume set to (0%)
20201230 101730 worker: -- System
20201230 101732 worker: Host     (moode)
20201230 101732 worker: moOde    (7.0.1 2020-12-23)
20201230 101732 worker: RaspiOS  (10.6)
20201230 101732 worker: Kernel   (5.4.77-v7+ #1371)
20201230 101732 worker: Platform (Pi-3B+ 1GB v1.3)
20201230 101732 worker: ARM arch (armv7l, 32-bit kernel)
20201230 101732 worker: MPD ver  (0.22.3_p0x3)
20201230 101732 worker: CPU gov  (ondemand)
20201230 101733 worker: USB boot enabled
20201230 101733 worker: File system expanded
20201230 101733 worker: HDMI port on
20201230 101733 worker: -- Network
20201230 101733 worker: eth0 exists
20201230 101733 worker: IP addr (192.168.1.7)
20201230 101733 worker: Netmask (255.255.255.0)
20201230 101733 worker: Gateway (192.168.1.1)
20201230 101733 worker: Pri DNS (222)
20201230 101733 worker: Domain  (208.67.222.)
20201230 101733 worker: wlan0 does not exist
20201230 101733 worker: -- Audio
20201230 101733 worker: MPD conf updated
20201230 101733 worker: ALSA outputs unmuted
20201230 101733 worker: ALSA card number (0)
20201230 101733 worker: Audio output (HiFiBerry DAC+ Pro)
20201230 101734 worker: Audio formats (S16_LE, S24_LE, S32_LE)
20201230 101734 worker: ALSA mixer name (Digital)
20201230 101734 worker: MPD volume control (software)
20201230 101734 worker: Hdwr volume controller exists
20201230 101734 worker: Max ALSA volume (100%)
20201230 101734 worker: Reset renderer active flags
20201230 101734 worker: -- MPD
20201230 101734 worker: MPD started
20201230 101734 worker: MPD accepting connections
20201230 101734 worker: Configure MPD outputs
20201230 101734 worker: MPD output 1 ALSA default (on)
20201230 101734 worker: MPD output 2 ALSA crossfeed (off)
20201230 101734 worker: MPD output 3 ALSA parametric eq (off)
20201230 101734 worker: MPD output 4 ALSA graphic eq (off)
20201230 101734 worker: MPD output 5 ALSA polarity inversion (off)
20201230 101734 worker: MPD output 6 ALSA bluetooth (off)
20201230 101734 worker: MPD output 7 HTTP stream (off)
20201230 101734 worker: MPD crossfade (off)
20201230 101734 worker: -- Feature availability
20201230 101734 worker: Source select (available)
20201230 101734 worker: Source select (source: MPD)
20201230 101734 worker: Source select (output: HiFiBerry DAC+ Pro)
20201230 101734 worker: Bluetooth (available)
20201230 101734 worker: Airplay renderer (available)
20201230 101734 worker: Spotify renderer (available)
20201230 101734 worker: Spotify renderer (started)
20201230 101734 worker: Squeezelite renderer (available)
20201230 101734 worker: UPnP renderer (available)
20201230 101734 worker: DLNA server (available)
20201230 101734 worker: UPnP browser (available)
20201230 101734 worker: GPIO button handler (available)
20201230 101734 worker: Stream recorder (n/a)
20201230 101734 worker: -- Music sources
20201230 101735 worker: USB sources (none attached)
20201230 101735 worker: NAS and UPnP sources (mountall initiated)
20201230 101735 worker: -- Miscellaneous
20201230 101735 worker: USB volume knob (Off)
20201230 101736 worker: LCD updater engine started
20201230 101736 worker: USB auto-mounter (udisks-glue)
20201230 101736 worker: LED0 (On)
20201230 101736 worker: LED1 (On)
20201230 101736 worker: Saved MPD vol level (0)
20201230 101736 worker: Preamp volume level (0)
20201230 101736 worker: MPD volume level (0) restored
20201230 101736 worker: ALSA Digital volume (100%)
20201230 101736 worker: Auto-play (Off)
20201230 101736 worker: LocalUI started
20201230 101736 worker: Maintenance interval (3 hrs)
20201230 101736 worker: Screen saver activation (Never)
20201230 101736 worker: Session permissions (OK)
20201230 101736 worker: Watchdog started
20201230 101736 worker: Ready
20201230 142459 waitWorker(): Start (sys-config, w_active=0)
20201230 142459 waitWorker(): End   (sys-config, w_active=0)
20201230 142500 enhanceMetadata(): error: currentsong file is NULL
20201230 142501 enhanceMetadata(): error: currentsong file is NULL
20201230 142504 enhanceMetadata(): error: currentsong file is NULL
20201230 142507 enhanceMetadata(): error: currentsong file is NULL
20201230 142510 enhanceMetadata(): error: currentsong file is NULL
20201230 142513 enhanceMetadata(): error: currentsong file is NULL
20201230 142516 enhanceMetadata(): error: currentsong file is NULL
Reply
#82
(12-30-2020, 05:42 PM)Alaini93 Wrote: Hi,
Reposting #36

I have a problem, when playing songs, everything is fine, when the system is paused or stopped (no more song playing), after 20 minutes the system get stuck, cannot login ssh, or access UI anymore from any devices.
I can see that chromium memory jumped to 75% here(usually 15%) and kswapd0 7%CPU.

What could be the problem?

............................................................   snip      .........................................................
@Alaini93
By the look of it (threads http://moodeaudio.org/forum/showthread.php?tid=3308 and  http://moodeaudio.org/forum/showthread.p...55&page=35) you are modding the standard MoOde build. This is NOT a criticism.
Is it possible that a certain config line may cause the trouble? Could you run a new unmodded build and test for a while?... and then introduce the addons one by one...?
Does the issue (<< the system get stuck, cannot login ssh, or access UI anymore from any devices  >>) happen when you pause any source, RADIO or NAS or external USB storage?
Reply
#83
(12-31-2020, 06:55 AM)CallMeMike Wrote: By the look of it (threads http://moodeaudio.org/forum/showthread.php?tid=3308 and  http://moodeaudio.org/forum/showthread.p...55&page=35) you are modding the standard MoOde build. This is NOT a criticism.
Is it possible that a certain config line may cause the trouble? Could you run a new unmodded build and test for a while?... and then introduce the addons one by one...?
Does the issue (<< the system get stuck, cannot login ssh, or access UI anymore from any devices  >>) happen when you pause any source, RADIO or NAS or external USB storage?

Hi Mike,

in my post I said I tested it without any modification.
NAS is my source, music is store on another computer.
But I remember having Moode getting stuck without playing anything after power on, and I realized that it was frozen after an hour, trying to play something.

I'm trying to get all my mods set up like 6.7.1, and I have multiple sdcards that I switch to try things.
Anyway, thanks for answering something, because it's radio silence on that one.
Reply
#84
After fresh install of 7.0.1, I noticed, there's this error in the moode.log. It doesn't go away even after reboot.

Code:
watchdog: Error: PHP session permissions (reapplied)
watchdog: Error: PHP session permissions (reapplied)
watchdog: Error: PHP session permissions (reapplied)
watchdog: Error: PHP session permissions (reapplied)
watchdog: Error: PHP session permissions (reapplied)

Quick troubleshooting revealed, that when the watchdog.sh is started during boot, the SESSION_FILE variable is malformed (sets to /var/local/php/sess_), because the db is not yet ready to return the sessionid. As a result, the ls -l fails to locate the file, PERMS remains empty, and the subsequent test evaluates to True:

https://github.com/moode-player/moode/bl...dog.sh#L49

As a remedy, I added a small check to wait until the sessionid is returned, and only then continue the execution of the rest lines. Tested locally, works fine, no more false errors in log, since PERMS is now correctly set to '-rw-rw-rw-,www-data,www-data' value.

To contribute the project, I raised a PR. Feel free to edit it, if you have more elegant solution:

https://github.com/moode-player/moode/pull/286/files
Reply
#85
I'll see if I can repro.
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#86
The session id is a static value in cfg_system and thus would always be returned but what I think is happening is the sql query is failing because the database is busy processing an update. It's due to an order of execution issue in worker.php. See the code snippet below.

Code:
// Start watchdog monitor
sysCmd('/var/www/command/watchdog.sh > /dev/null 2>&1 &');
workerLog('worker: Watchdog started');

//
workerLog('worker: Ready');
$result = sdbquery("UPDATE cfg_system SET value='1' WHERE param='wrkready'", $dbh);
//

//
// BEGIN WORKER JOB LOOP
//

The fix would be to start watchdog after the update query for "worker: ready".

If you cold revert your change to watchdog and test this fix I'd be interested in knowing the results.

-Tim
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#87
Hi,

 Here what I get after power it on this morning, didn't play any song, just left it on with "top" running to monitor.
Of course now it's stuck, cannot access UI from anywhere, and SSH is stuck too.

If it's something that nobody wants to look at, you need to tell me, I will stay with 6.7.1


Attached Files Thumbnail(s)
   
Reply
#88
(12-31-2020, 07:48 PM)Tim Curtis Wrote: The session id is a static value in cfg_system and thus would always be returned but what I think is happening is the sql query is failing because the database is busy processing an update. It's due to an order of execution issue in worker.php. See the code snippet below.

Code:
// Start watchdog monitor
sysCmd('/var/www/command/watchdog.sh > /dev/null 2>&1 &');
workerLog('worker: Watchdog started');

//
workerLog('worker: Ready');
$result = sdbquery("UPDATE cfg_system SET value='1' WHERE param='wrkready'", $dbh);
//

//
// BEGIN WORKER JOB LOOP
//

The fix would be to start watchdog after the update query for "worker: ready".

If you cold revert your change to watchdog and test this fix I'd be interested in knowing the results.

-Tim

Yes, it is the sql query that fails. I was not very precise in my wording initially.

OK, I'll test this in coming days.

See you in 2021 Smile
Reply
#89
(12-31-2020, 08:00 PM)Alaini93 Wrote: Hi,

 Here what I get after power it on this morning, didn't play any song, just left it on with "top" running to monitor.
Of course now it's stuck, cannot access UI from anywhere, and SSH is stuck too.

If it's something that nobody wants to look at, you need to tell me, I will stay with 6.7.1

If you can provide a list of steps that can be used to reproduce your issue then it might be possible to troubleshoot.
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#90
(12-31-2020, 08:24 PM)Tim Curtis Wrote: If you can provide a list of steps that can be used to reproduce your issue then it might be possible to troubleshoot.

ok,
Flash moode-r701-iso.zip with BalenaEtcher
Power on,

System:
expand file system, restart
set time zone
set wifi BT off, restart
local display On Mouse Off, restart
Set screen blank 1 min, Wake dispaly ON, brightness 
Metadatafile ON, restart
LCD update engine ON

Network:
Set Static IP, restart

Audio:
Set Device, restart
Set Spotify.

Library:
Set NAS source.
Update library.

Preference:
Coverview, automatic display 1 min

Go to config.txt set blanking=0
restart


Here are all the steps.

BTW, is there a way to save that setting, so we don't have to spend 10 mins resetting everything every time we reflash?
Reply


Forum Jump: